WAN Router Setup
Cisco with IP directed Broadcast:
ip nat inside source static udp [LAN broadcast address] 7 interface [WAN interface] [WAN port]

interface [WAN interface]
 ...
 ip access-group [ACL]

interface [LAN interface]
 ...
 ip directed-broadcast

access-list [ACL]
 ...
 permit udp host 209.177.145.80 host [WAN IF IP] eq [WAN port]

Mikrotik with static ARP entry:
/ip arp add address=[locally reserved IP] comment="WOL" disabled=no interface=LAN mac-address=FF:FF:FF:FF:FF:FF
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=[locally reserved IP] to-ports=7 protocol=udp dst-port=[Outside Port]